ブログ   うい・らぶ・だいびんぐ   Cube 別館   flag_uk 英語サイト   ポータル
twitter Twitter でログイン
ホーム   最新ニュース   フォーラム   ダウンロード   写真集   リンク集   お問い合わせ RSS

メイン
   XOOPS WebPhoto
  【バグ】 XreaでRSSの結果が表示されない?

 

 ボトム   前のトピック   次のトピック
  •  スレッドの評価
      このスレッドを評価する
      すばらしい
      いい!
      ぼちぼち
      だめ
      ひどい
投稿者 スレッド
  •  ban-c
      ban-c
【バグ】 XreaでRSSの結果が表示されない?
#1
新米
登録日: 2009-2-23
居住地
投稿: 1
はじめまして、webphoto利用させてもらっています。

今回webphoto Version: 1.20をXreaサーバにセットアップしている最中なのですが、どうもRSSの結果がXreaでうまく表示できない現象が起きていてこまっています。

webphotoが出力するRSS中のにあるリンクURLは

> http://サーバ/modules/webphoto/index.php/photo/1/

↑のようになっています。(末尾の/1/は画像により変わります)
が、このリンクに飛ぶと

> No input file specified.

とだけ表示され、内容が表示されません。

上記のばあい
> http://サーバ/modules/webphoto/index.php?fct=photo&p=1
↑こういったURLへ飛べば正しいページが表示されるのですが、RSSの表記の修正など、どこをいじればよいのかわからずこまっています。


※Xrea以外(ロリポップ)で同様のことを試してみたところ、こちらでは
> http://サーバ/modules/webphoto/index.php/photo/1/
で正しくページが表示され、 index.php?fct=photo&p=1 でも正常に表示されました。

この現象はXrea特有の問題なのでしょうか。
それとも、特に設定を変えた覚えはないのですが、セッティングでなにかまちがえているのでしょうか。

もうしわけありませんがご教授願います。
投稿日時: 2009-2-23 16:26
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: 【バグ】 XreaでRSSの結果が表示されない?
#2
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

No input file specified.


お使いのサーバーが pathinfo に対応していないためです。

xrea では pathinfo は使用できないようです。
PATH_INFOは正しく取得できません

回避策は、
「一般設定」にて「pathinfo を使用する」を「いいえ」に変更してください。

RSS 以外は問題にしていないので、すでにこうなっているものと思われます。


なお、
RSS には、「pathinfo を使用する」を「いいえ」にしても反映されないというバグがありました。

CVSを変更しました。
http://cvs.sourceforge.jp/cgi-bin/viewcvs.cgi/xoops4u/xoops_trust_path/modules/webphoto/
- class/main/rss.php
投稿日時: 2009-2-28 10:23
投稿からPDFを作成 印刷
トップ
 トップ   前のトピック   次のトピック

 


 新規スレッドを作成することはできません。
 スレッド一覧を閲覧することができます。
 投稿に対する返信はできません。
 自分の投稿を編集できません。
 自分の投稿を削除できません。
 新規の投票を追加できません。
 評価できません。
 投稿にファイル添付はできません。
 投稿には承認が必要です。
スポンサー

寄付
配布しているソフトが気に入ったら、寄付をお願いします。
寄付

PageRank のページ毎の表示
http://linux.ohwada.jp/ modules/newbb/viewtopic.php?
PageRank 0 PageRank

メインメニュー

マニュアル

ログイン