ブログ   うい・らぶ・だいびんぐ   Cube 別館   flag_uk 英語サイト   ポータル
twitter Twitter でログイン
ホーム   最新ニュース   フォーラム   ダウンロード   写真集   リンク集   お問い合わせ RSS

メイン
   XOOPS WebPhoto
  Webphotoで、Googleマップが表示されない

 

 ボトム   前のトピック   次のトピック
  •  スレッドの評価
      このスレッドを評価する
      すばらしい
      いい!
      ぼちぼち
      だめ
      ひどい
投稿者 スレッド
  •  nonn50
      nonn50
Webphotoで、Googleマップが表示されない
#1
一人前
登録日: 2005-3-5
居住地 石川県野々市市
投稿: 81
毎度、お世話になります。

Webphoto 2.12で、Googleマップ及びタイムラインが表示されなくなりました。

少なくとも、Webphoto 2.10 では、表示されておりました。
解決策を教えていただきたく、よろしくお願いします。

【事象】
1.TOP画面「http://hogehoge/modules/webphoto/」
を表示させた場合、Googleマップ及びタイムラインが表示されない。
(「Loading ...」が表示されたまま、画面が変わらない。)

-PHPデバッグでは、以下のエラーです(関係無さそう)
Warning [PHP]: chmod() [function.chmod]: Operation not permitted in file xoops_trust_path/modules/webphoto/class/inc/auto_publish.php line 137
Warning [PHP]: chmod() [function.chmod]: Operation not permitted in file xoops_trust_path/modules/webphoto/class/inc/auto_publish.php line 137


2.投稿画面「http://hogehoge/modules/webphoto/index.php/submit/」においては、「画像アップロード」で表示されていたGoogleマップが表示されない。

-PHPデバッグでは、以下のエラーです
Warning [PHP]: chmod() [function.chmod]: Operation not permitted in file xoops_trust_path/modules/webphoto/class/inc/auto_publish.php line 137


【モジュールの版】
Webphoto 2.12
タイムライン モジュール 0.11

【補足】
●貴サイトが提供する「Google Maps (webmap)v0.11」及び他サイトが提供するGNAVI D3 及び xpWikiの Googleマップ機能は、正常に動作しています。
●本質問に気づいたのは、「XOOPS Cube Legacy 2.1.7 ⇒ 2.1.8」、「Webphoto 2.10 ⇒ 2.12」と版UPを行ってからです。
過日こちらで御教授いただいた「スライドショーのベタ書き」については、本件に気づいてから、現在は取り外してありますが、改善されていません。


サーバー環境
OS: Linux
PHP: 4.4.8
MySQL: 4.0.26
XOOPS: XOOPS Cube Legacy 2.1.8(EUC-JP)
投稿日時: 2010-4-10 16:50
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphotoで、Googleマップが表示されない
#2
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

Webphoto 2.12で、Googleマップ及びタイムラインが表示されなくなりました。


こちらでは再現しないので、
提供いただいた情報だけでは、何もできないですね。

引用:

「XOOPS Cube Legacy 2.1.7 ⇒ 2.1.8」、「Webphoto 2.10 ⇒ 2.12」と版UPを行ってからです。


念のため
XOOPS Cube Legacy 2.1.8 + Webphoto 2.12 の環境を作って確認したが、
問題なし。

引用:

Warning [PHP]: chmod() [function.chmod]: Operation not permitted in file xoops_trust_path/modules/webphoto/class/inc/auto_publish.php line 137


下記のファイルの属性を確認してください。
一度削除してみるのも手。
xoops_trust_path/modules/webphoto/uploads/webphoto/log/auto_publish
投稿日時: 2010-4-11 14:25
投稿からPDFを作成 印刷
トップ
  •  nonn50
      nonn50
Re: Webphotoで、Googleマップが表示されない
#3
一人前
登録日: 2005-3-5
居住地 石川県野々市市
投稿: 81
お世話になります。


引用:

念のため
XOOPS Cube Legacy 2.1.8 + Webphoto 2.12 の環境を作って確認したが、
問題なし。


お手数をお掛けし、すみません。

引用:

下記のファイルの属性を確認してください。
一度削除してみるのも手。
xoops_trust_path/modules/webphoto/uploads/webphoto/log/auto_publish


/xoops_trust_path/modules/webphoto/uploads/ ⇒ 777
/xoops_trust_path/modules/webphoto/uploads/webphoto/ ⇒ 707
/xoops_trust_path/modules/webphoto/uploads/webphoto/log/ ⇒ 707

です。

御指導いただきました

/xoops_trust_path/modules/webphoto/uploads/webphoto/log/auto_publish

については、確認した時点では777であり所有者はレンタル人の私となっていました。
一度削除した後に再確認しましたら、所有者はapacheに変わりパミッションは777となっている状態です。


引用:

こちらでは再現しないので、
提供いただいた情報だけでは、何もできないですね。


お役に立つか解りませんが、もう少し情報をかき集めました。

1.本件の状況確認をしたブラウザ
IE8, Firfox, Opera, chrome


2.動作チェッカーの出力

動作チェッカー


環境チェック
OS: Linux 13.pro.tok2.com 2.6.18-92.1.6.el5 #1 SMP Wed Jun 25 13:49:24 EDT 2008 i686
PHP: 4.4.8
MySQL: 4.0.26-log
XOOPS: XOOPS Cube Legacy 2.1.8
Webphoto: 2.12

MySQL 設定
PHP設定
register_globals: off ( 推奨 off )
allow_url_fopen: on ( 推奨 off )
file_uploads: on ( 要on )
upload_max_filesize: 5M
post_max_size: 8M
upload_tmp_dir :
error_reporting: 0
display_errors: 1
memory_limit: 32
magic_quotes_gpc: 0
safe_mode: 0
open_basedir:
exif extention: loaded

マルチバイト 設定
multibyte function priority: iconv

mbstring.language: Japanese
mbstring.detect_order: ASCII JIS UTF-8 EUC-JP SJIS
mbstring.http_input: pass
mbstring.http_output: pass
mbstring.internal_encoding: EUC-JP
mbstring.script_encoding:
mbstring.substitute_character: none
mbstring.func_overload: 0
mbstring.encoding_translation: 0
mbstring.strict_encoding: 0

iconv.input_encoding: EUC-JP
iconv.output_encoding: EUC-JP
iconv.internal_encoding: EUC-JP

文字コード変換が動くかどうかのチェック (UTF-8) ⇒ok
文字コード変換が動くかどうかのチェック (Shift_JIS) ⇒ok

Pathinfo が動くかどうかのチェック ⇒ok


設定チェック
画像処理プログラム :

GD
GD Version: bundled (2.0.28 compatible)

GD2(truecolor)モードが動くかどうかのチェック ⇒ok

QRコードが表示できるかのチェック ⇒ok


ImageMagick
Path:
Version: ImageMagick 6.2.8 04/17/08 Q16 file:/usr/share/ImageMagick-6.2.8/doc/index.html


FFmpeg
Path:
Error: ffmpeg can't be executed

lame : not use

timidity : not use

xpdf : not use

jodconverter : not use


Directory :

アップロード・ディレクトリ: /hogehoge/uploads/webphoto ok

一時ファイル ディレクトリ: /hogehoge/xoops_trust_path/modules/webphoto/uploads/webphoto
このディレクトリはゲストも読むことが出来ます
ドキュメント・ルート以外に設定することをお勧めします

FTP ファイル ディレクトリ: not set



ファイルの妥当性の検査 ⇒ok


タイムライン・モジュール
dirname : timeline
version : 0.11


コマンドの管理
コマンドのテスト実行: bin/retrieve.php ⇒no(以下のエラーが発生

Fatal error: Undefined class name 'webphoto_edit_item_create' in /hogehoge/xoops_trust_path/modules/webphoto/class/edit/base.php on line 40


【追補】
以上のような状況ですが、質問いたしました内容について変化はありません

Webphoto以外にも、「XOOPS Cube Legacy 2.1.7 ⇒ 2.1.8」にしてから不具合が発生しているモジュールがあります。
(小生のレンタルサーバーに限った事象かも知れません。)

小生としては、XCL 2.20のリリース時に類似した問題が発生することを想定しておりまして、現時点で本件等を追及する気持ちが失せ掛けております。

というわけで、他ユーザーより類似問題の申告が無ければ、本件はソコソコで結構です。
投稿日時: 2010-4-11 18:05
投稿からPDFを作成 印刷
トップ
  •  nonn50
      nonn50
Re: Webphotoで、Googleマップが表示されない
#4
一人前
登録日: 2005-3-5
居住地 石川県野々市市
投稿: 81
XOOPS Cube Legacy 2.2.0 Alpha 2 Released! がリリースされ、動作環境が
PHP:5.0以上
MySQL:MySQL server 5.0以上
と、小生のレンタルサーバーの能力を上回るものであることが判明しました。

そこで小生といたしましては、# XOOPS Cube Legacy 2.1.8 にて、Webphoto 2.12が動作するようにする必要性にせまられましたので、お手数でしょうが、引き続き御指南ねがいます。

とりあえず、前回の質問について、ご解答いただきたく、よろしくお願いします。

引用:

コマンドの管理
コマンドのテスト実行: bin/retrieve.php ⇒no(以下のエラーが発生

Fatal error: Undefined class name 'webphoto_edit_item_create' in /hogehoge/xoops_trust_path/modules/webphoto/class/edit/base.php on line 40

投稿日時: 2010-4-17 16:38
投稿からPDFを作成 印刷
トップ
  •  nonn50
      nonn50
Re: Webphotoで、Googleマップが表示されない【解決】
#5
一人前
登録日: 2005-3-5
居住地 石川県野々市市
投稿: 81
Webphotoモジュールと一緒に表示させていたブロックを削減したところ、Googleマップ及びタイムラインともに表示されるようになりました。


小生の欲張り過ぎであったようです。
大変、お騒がせしました。

※しかし、前述の「コマンドのテスト実行」に関するエラーは解消されておりませんので、引き続き、よろしくお願いします。


追伸
XCL 2.1.7では、今回の対策で「ブロック表示させない」こととしたブロックを表示させても問題無かったのですが、XCL 2.1.8はメモリーを消費するようになったのでしょうかね〜
投稿日時: 2010-4-19 15:12
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphotoで、Googleマップが表示されない
#6
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

Fatal error: Undefined class name 'webphoto_edit_item_create' in /hogehoge/xoops_trust_path/modules/webphoto/class/edit/base.php on line 40


バグ報告 ありがとうございます。

CVSを変更しました
http://cvs.sourceforge.jp/cgi-bin/viewcvs.cgi/xoops4u/xoops_trust_path/modules/webphoto/
- bin/retrieve.php
投稿日時: 2010-4-22 12:37
投稿からPDFを作成 印刷
トップ
  •  nonn50
      nonn50
Re: Webphotoで、Googleマップが表示されない
#7
一人前
登録日: 2005-3-5
居住地 石川県野々市市
投稿: 81
毎度お世話様です。

本件、正常動作することを確認しました。

今後とも、よろしくお願いします。
投稿日時: 2010-4-23 19:55
投稿からPDFを作成 印刷
トップ
 トップ   前のトピック   次のトピック

 


 新規スレッドを作成することはできません。
 スレッド一覧を閲覧することができます。
 投稿に対する返信はできません。
 自分の投稿を編集できません。
 自分の投稿を削除できません。
 新規の投票を追加できません。
 評価できません。
 投稿にファイル添付はできません。
 投稿には承認が必要です。
スポンサー

寄付
配布しているソフトが気に入ったら、寄付をお願いします。
寄付

PageRank のページ毎の表示
http://linux.ohwada.jp/ modules/newbb/viewtopic.php?
PageRank 0 PageRank

メインメニュー

マニュアル

ログイン