ブログ   うい・らぶ・だいびんぐ   Cube 別館   flag_uk 英語サイト   ポータル
twitter Twitter でログイン
ホーム   最新ニュース   フォーラム   ダウンロード   写真集   リンク集   お問い合わせ RSS

メイン
   XOOPS WebLinks
  weblinksから「バージョン 1.90ではない」というエラー

 

 ボトム   前のトピック   次のトピック
12>
  •  スレッドの評価
      このスレッドを評価する
      すばらしい
      いい!
      ぼちぼち
      だめ
      ひどい
投稿者 スレッド 評価:  4 評価
  •  linyknjp
      linyknjp
weblinksから「バージョン 1.90ではない」というエラー
#1
新米
登録日: 2008-9-25
居住地
投稿: 4
みなさんこんにちは

hd102を古いサーバーから新しいサーバーに移転しました。weblinksを復元した後、管理画面の目次、モジュールの設定2で「バージョン 1.90ではない」というメッセージが出ます。設定テーブルをアップグレードするというボタンをクリックしても、何も変わらなかった。ご存じの方、教えていただければ幸いです。

古いサーバー環境:PHP バージョン 4.4.7 MySQL バージョン 4.0.26-standard

新しいサーバー環境:PHP バージョン 5.2.6 MySQL バージョン 4.1.21 with JP patch
投稿日時: 2008-9-25 16:17
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: weblinksから「バージョン 1.90ではない」というエラー
#2
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

「バージョン 1.90ではない」というメッセージが出ます。


過去5年分のバージョンアップの項目をチェックしています。
そのどこかでエラーになったということです。

引用:

設定テーブルをアップグレードするというボタンをクリックしても、何も変わらなかった。


自動的に更新できない種類のエラーということです。

対応は。
まずは、普通にインストールしてみましょう。

おかしな現象に遭遇したら、
原点に帰って、そこから一歩一歩確認しながら作業するのが、
解決までの早道です。


引用:

weblinksを復元した後、


復元って、どうやったのですか?
投稿日時: 2008-9-28 19:35
投稿からPDFを作成 印刷
トップ
  •  linyknjp
      linyknjp
Re: weblinksから「バージョン 1.90ではない」というエラー
#3
新米
登録日: 2008-9-25
居住地
投稿: 4
管理者さま
こんにちは、weblinksのデータを復元しなくても、例のエラーも出てます。ちなみに、weblinks1.91も同じ状況です。インストールした直後、管理画面の目次、モジュールの設定2をクリックしたら、「バージョン 1.90ではない」が出ました
投稿日時: 2008-9-28 22:19
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: weblinksから「バージョン 1.90ではない」というエラー
#4
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

インストールした直後、管理画面の目次、モジュールの設定2をクリックしたら、「バージョン 1.90ではない」が出ました


メモリ不足かも
下記を参照ください。
weblinkの「モジュールの設定」画面が真っ白
投稿日時: 2008-10-11 17:41
投稿からPDFを作成 印刷
トップ
  •  linyknjp
      linyknjp
Re: weblinksから「バージョン 1.90ではない」というエラー
#5
新米
登録日: 2008-9-25
居住地
投稿: 4
管理人様:

ご回答を頂きありがとうございます。私は一度チェックしましたがPHP バージョン 5.2.6なので、メモリリミットは128Mと設定されております。

他には御座いませんでしょうか
投稿日時: 2008-10-15 9:15
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: weblinksから「バージョン 1.90ではない」というエラー
#6
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

メモリリミットは128Mと設定されております。


では、原因はメモリリミットではないですね。

う〜ん、自力でデバックしてもらうしかないか。

バージョンチェックをしているのは、
- class/weblinks_install.php
です。
投稿日時: 2008-10-18 19:41
投稿からPDFを作成 印刷
トップ
  •  yshima
      yshima
Re: weblinksから「バージョン 1.90ではない」というエラー
#7
新米
登録日: 2005-8-7
居住地
投稿: 13
ken さん こんにちは、

MySQL 4.1 以降、255 文字を超える長さを持つ VARCHAR 型のフィールドは、TEXT 型に変換されることが原因ではないでしょうか?

参考ページ:カラムの暗黙的な変更
投稿日時: 2008-11-27 0:45
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: weblinksから「バージョン 1.90ではない」というエラー
#8
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

MySQL 4.1 以降、255 文字を超える長さを持つ VARCHAR 型のフィールドは、TEXT 型に変換されることが原因ではないでしょうか?


どこからそういう話になるのでしょうか?

Weblinks では、255 文字を超える VARCHAR 型は使っていないし。
暗黙的な変更なので、それが原因になることはないはず。
投稿日時: 2008-11-30 8:41
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: weblinksから「バージョン 1.90ではない」というエラー
#9
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

う〜ん、自力でデバックしてもらうしかないか。


下記の変更をすると、SQL文の実行トレースが表示されます。
それをここに貼り付けてください。

modules/happy_linux/class/module_install.php
32行目

//var $_DEBUG_SQL   = false;
//var $_DEBUG_ERROR = false;
 ↓
var $_DEBUG_SQL   = true;
var $_DEBUG_ERROR = true;
投稿日時: 2008-11-30 8:45
投稿からPDFを作成 印刷
トップ
  •  yshima
      yshima
Re: weblinksから「バージョン 1.90ではない」というエラー
#10
新米
登録日: 2005-8-7
居住地
投稿: 13
引用:
Weblinks では、255 文字を超える VARCHAR 型は使っていないし。

失礼しました。過去の私のSQLを見てしまいました。

引用:
暗黙的な変更なので、それが原因になることはないはず。

勉強不足で申し訳ございません。

最近、レンタルサーバの変更を行ったのですが、linyknjp さんと同じ環境のようなのでバージョン 1.92 を入れてみました。UTF-8 で運用しています。

インストール成功しますが、「バージョン 1.92 ではない」と怒られました。
「カテゴリの管理」から入ると全ての管理項目の設定変更が可能。
「DBテーブル管理」を見ると「weblinks_config2」などでFatal Error。
「varchar」で作成したカラムが「varbinary」に「text」で作成したカラムが「blob」になっていました。
投稿日時: 2008-12-1 5:17
投稿からPDFを作成 印刷
トップ
 トップ   前のトピック   次のトピック
12>

 


 新規スレッドを作成することはできません。
 スレッド一覧を閲覧することができます。
 投稿に対する返信はできません。
 自分の投稿を編集できません。
 自分の投稿を削除できません。
 新規の投票を追加できません。
 評価できません。
 投稿にファイル添付はできません。
 投稿には承認が必要です。
スポンサー

寄付
配布しているソフトが気に入ったら、寄付をお願いします。
寄付

PageRank のページ毎の表示
http://linux.ohwada.jp/ modules/newbb/viewtopic.php?
PageRank 0 PageRank

メインメニュー

マニュアル

ログイン