ブログ   うい・らぶ・だいびんぐ   Cube 別館   flag_uk 英語サイト   ポータル
twitter Twitter でログイン
ホーム   最新ニュース   フォーラム   ダウンロード   写真集   リンク集   お問い合わせ RSS

メイン
   XOOPS WebPhoto
  【バグ】 Webphoto モジュール 0.50版での障害

 

 ボトム   前のトピック   次のトピック
  •  スレッドの評価
      このスレッドを評価する
      すばらしい
      いい!
      ぼちぼち
      だめ
      ひどい
投稿者 スレッド
  •  hayasibe
      hayasibe
【バグ】 Webphoto モジュール 0.50版での障害
#1
一人前
登録日: 2004-12-27
居住地
投稿: 92
XOOPS 2.1.5環境では、問題なくアップデートは完了しました。
※すいません、XOOPS2.1.5環境での新規インストールは確認していません。

ただし、今回、どうしてもXCLの動作が重いのが気になって、XOOPS JPのアップ版であるXOOPS JPEx(http://www.xoops-ri.jp/jpex/ )をXOOPS公式サイト上で発見し利用しつつあります。
かなり細かいところでバージョンアップされてて気に入ってます。

今回、を上記XOOPS JPExにアップしたのですが、いくつか不具合かな・・という現象が出ています。


(1)管理画面でのメニューの重複
添付した画像のように管理画面でメニューが重複しています。


(2)「No input file specified」というエラー
※ひとまず、解決済み・・かなと思うのですが、モジュール側で対応していただけるのであれば・・と思いますご連絡まで。

サイトトップにてWebphotoモジュールにアクセスし、
新着 | 高人気 | トップランク | ランダム写真 | 自分の投稿
などのメニューをクリックすると、すべて、「No input file specified」というエラーが表示されます。

ただし、利用しているサーバーがCoreserverということで、セーフモード動作ということで、下記を参考に対応させていただいています。
http://hikariworks.jp/blog/2007/09/22/


(3)画像投稿エラー

画像を投稿しようとすると、下記のようなエラーが表示されます。

Fatal error: Call to a member function fetchMedia() on a non-object in /virtual/home/public_html/xoops_trust_path/modules/webphoto/class/webphoto/upload.php on line 154

ただし、YOUTUBEなどの動画系サイトの登録はサムネイルも表示されて問題ないようです。

もし、XOOPS JPExがサポート外であれば、他のXOOPSバージョンで考え直そうかと思っています。

よろしくお願いします。



添付ファイル: jpg  webphoto1.jpg (29.67 KB)


152_490e54d91de46.jpg 500X146 px
投稿日時: 2008-11-3 10:33
投稿からPDFを作成 印刷
トップ
  •  hayasibe
      hayasibe
Re: Webphoto モジュール 0.50版での障害
#2
一人前
登録日: 2004-12-27
居住地
投稿: 92
XOOPS2.1.5環境で、画像の投稿エラーが同様に出ました。
動作チェックでエラー表示はありません。(XOOPS JPEx同様)
ただし、コマンドの管理のところで「コマンドのテスト実行: bin/retrieve.php」を行うと、下記エラーが表示されます。(XOOPS JPEx同様)

Fatal error: Class 'webphoto_kind' not found in /virtual/home/public_html/xoops_trust_path/modules/webphoto/class/webphoto/base_this.php on line 89
投稿日時: 2008-11-3 10:53
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphoto モジュール 0.50版での障害
#3
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

(1)管理画面でのメニューの重複


報告 ありがとうございます。

これは、JPEx 特有の現象です。
「管理画面に水平メニュー追加」が悪さをしています。
メニューの表示の有無を mymenu.php というファイルの有無で判定しているようです。

対策としては、mymene.php (中身は空) を追加します。

CVS に追加しました
http://cvs.sourceforge.jp/cgi-bin/viewcvs.cgi/xoops4u/xoops_trust_path/modules/webphoto/
- admin/mymenu.php
投稿日時: 2008-11-3 20:21
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphoto モジュール 0.50版での障害
#4
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

コマンドのテスト実行
Fatal error: Class 'webphoto_kind' not found in /virtual/home/public_html/xoops_trust_path/modules/webphoto/class/webphoto/base_this.php on line 89


バグ報告 ありがとうございます。

確認漏れですね。

CVS を変更しました
http://cvs.sourceforge.jp/cgi-bin/viewcvs.cgi/xoops4u/xoops_trust_path/modules/webphoto/
- bin/retrieve.php
投稿日時: 2008-11-3 20:24
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphoto モジュール 0.50版での障害
#5
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

(2)「No input file specified」というエラー
ひとまず、解決済み・・かなと思うのですが、


解決済みとは、"mod_gzip_on Off" のことですか。

なぜこれで直るのか分からないが。
下記から推測すると、PATH_INFO との相性のようです。

http://www.symfony-project.org/forum/index.php/t/2620/
引用:

3 - no_script_name can cause problems with URL, this seems to be caused by the apache gzip module having trouble with symfony URL (sometimes it can't find the data to compress), you can disable this module by adding this to the .htaccess file in your www directory :


webphoto の一般設定に「pathinfo を使用する」があります。
これを「いいえ」にして、どうなるか試してみてください。
投稿日時: 2008-11-3 20:40
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphoto モジュール 0.50版での障害
#6
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

(3)画像投稿エラー
Fatal error: Call to a member function fetchMedia() on a non-object in /virtual/home/public_html/xoops_trust_path/modules/webphoto/class/webphoto/upload.php on line 154


これは再現しません。
エラーとなったところのソースコードを見てみたが、
おかしなところはないようです。


Coreserver には下記の注意書きがありますね。
スクリプト・キャッシュの誤動作は、私も経験があります。
キャッシュ・オフを試してみてください。

http://www.coreserver.jp/help/index.php/phperror/
引用:

可能性として、運用されているPHPスクリプトと、サーバー側でのPHP高速化・キャッシュモジュールとの相性の問題が発生していることがあります。
投稿日時: 2008-11-3 20:48
投稿からPDFを作成 印刷
トップ
  •  hayasibe
      hayasibe
Re: Webphoto モジュール 0.50版での障害
#7
一人前
登録日: 2004-12-27
居住地
投稿: 92
ご返答ありがとうございます。

引用:

これは再現しません。
エラーとなったところのソースコードを見てみたが、
おかしなところはないようです。

Coreserver には下記の注意書きがありますね。
スクリプト・キャッシュの誤動作は、私も経験があります。
キャッシュ・オフを試してみてください。


すいません、(3)画像投稿エラーとしていたのですが、実際は、投稿時ではなくて、プレビューボタンをクリックした時でした。
プレビューボタンをクリックした後に、下記が表示されます。
Fatal error: Call to a member function fetchMedia() on a non-object in /virtual/home/public_html/xoops_trust_path/modules/webphoto/class/webphoto/upload.php on line 154

プレビューボタンをクリックせずに、追加ボタンをクリックすると、画像はきちんと登録されます。

すいません、私の認識間違いでした。

ちなみに、キャッシュ・オフを試して見ましたが、プレビューボタンでの上記エラーは回避できませんでした。
投稿日時: 2008-11-3 23:17
投稿からPDFを作成 印刷
トップ
  •  ken
      ken
Re: Webphoto モジュール 0.50版での障害
#8
管理人
登録日: 2003-9-6
居住地 横浜
投稿: 2519
引用:

プレビューボタンをクリックした後に、下記が表示されます。
Fatal error: Call to a member function fetchMedia() on a non-object in /virtual/home/public_html/xoops_trust_path/modules/webphoto/class/webphoto/upload.php on line 154


バグ報告ありがとうございます。
今度は再現しました。

CVS を変更しました
http://cvs.sourceforge.jp/cgi-bin/viewcvs.cgi/xoops4u/xoops_trust_path/modules/webphoto/
- class/main/submit.php
- class/webphoto/photo_action.php
- class/webphoto/photo_create.php
- class/webphoto/photo_edit.php


この種のバグの作り込みの要因として。
プログラムがスパゲティ状態になっていることがあります。
Fatal error という明確なメッセージが出ているので、
ソースレビューである程度あたりがつかないと、イカンはずです。
プログラム構造を見直すことにします。

また、「スクリプト・キャッシュ」とか他に原因を求めては、イカンですね。
深く反省。
投稿日時: 2008-11-4 23:37
投稿からPDFを作成 印刷
トップ
 トップ   前のトピック   次のトピック

 


 新規スレッドを作成することはできません。
 スレッド一覧を閲覧することができます。
 投稿に対する返信はできません。
 自分の投稿を編集できません。
 自分の投稿を削除できません。
 新規の投票を追加できません。
 評価できません。
 投稿にファイル添付はできません。
 投稿には承認が必要です。
スポンサー

寄付
配布しているソフトが気に入ったら、寄付をお願いします。
寄付

PageRank のページ毎の表示
http://linux.ohwada.jp/ modules/newbb/viewtopic.php?
PageRank 0 PageRank

メインメニュー

マニュアル

ログイン